PDA

View Full Version : The problem of Shadow Stepping/teleportation...



The Experimentor
24-03-2006, 16:28
http://i46.photobucket.com/albums/f107/Experimentor/Guild%20Wars%20Stuff/gw025.jpg

http://i46.photobucket.com/albums/f107/Experimentor/Guild%20Wars%20Stuff/gw026.jpg

DEATH'S CHARGE
Description: Shadow Step to target foe. If that foe has more Health than you, you are healed for 40-112.
Energy Cost:[/b] 5
Activation Time: 1 Second.
Recharge Time: 45 Seconds.
Linked Attribute: Shadow Arts. Increases health recovered.
Skill Type: Spell.

I was exploring the map directly outside the gates of The Marketplace. Head East and you'll find a portion of the city under construction and inhabited by, I'm guessing, renegade guilds of humans, namely the Jade Brotherhood (Warriors, Ritualists, Elems and an Assassin boss), the Am Ho (Necros and Assassins), and the Afflicted (Necros and Assassins).

First, the cleanest and nearest part of the construction is inhabited by the Jade Brotherhood. Go further East and you find a dirty, swampy place at what seems to be a sewer or waste disposal area of the city where you will first find the Am Ho. Go inside and the furthest East are the Afflicted.

Here's the thing: I'd been using the Assassin's Death's Charge to close with my target and get into combat instantly. Now, my target during one of those fights was an Afflicted Necromancer.

If you look around the second picture here, you will see all sorts of scaffolding and construction frameworks.

At the time, my target was standing next to one of those constructions. It was a pillar, I guess, mainly just framework and scaffolding, mostly empty space inside.

I activated Death's Charge...

... and teleported INSIDE the framework construct next to my target.

I couldn't move at all, and I was still too far to attack him. I was literally stuck in place in an obstacle I shouldn't even normally be able to get in.

What was worse, he was the last living enemy in the area, so I couldn't target anything else with Death's Charge to get out.

I noticed a passing Animal, a Reef Lurker (we call them crabs), and I decided to try attacking it, turning it hostile so I could target it with Death's Charge.

Unforunately, in the chaos of it all, I pressed the wrong button, and my party of 8, including the Tengu Warrior henchman, my two Assassin henchmen, quickly slaughtered the poor, innocent creature.

I had to map travel back to The Marketplace to get out, and had to do things all over again.

I'm going to report this to the Bugs forums. ANet should know about this to prevent players from experiencing teleport grief when Factions comes out.

Calis
25-03-2006, 18:40
I had the same thing happen to me, in a similar area. Be wary, where you step assassins.

wreckin crew
26-03-2006, 00:23
lol happened to me during a competitive mission. I teleported onto a rock that i couldn't get off of lol

dorsai
26-03-2006, 00:40
This actually isnt a wholly new problem. I encountered something of similar nature in a kryta mission (cant remember which) when I used necrotic transversal. We killed a drake under thr bridge and I used necrotic transversal, then poof, I was on top of where a drawbridge opens later in the mission. Only it wasn't open yet. That didn't stop me from walking on thin air, though =/ Couldnt get back down to everyone else, and had to wait until they cleared as far as I was.

Silent Elegy
27-03-2006, 01:32
The same thing happens in Riverside Mission with Necros (me included) who use Necrotic Trasversal, they end up stuck on top of the towers.

Also happened to me earlier in the Beach Alliance Battle. I ended up stuck on a rock at the dragon shrine, and couldn't move. When I tried to use Death's Charge to get off, it wouldn't work. The other team was having a lot of fun killing me down to about 10hp, then letting me regen before killing me down again. And laughing. Lol

Zero
27-03-2006, 02:13
Yeh thats a real problem and needs to be fixed, teleporting still seems pretty buggy. The other problem you'll probably encounter (i know I have...) is teleporting above/below bridges and the like. Since the game has no Z axis it's not garunteed you'll teleport onto the level you want. This is why we can attack in melee range people who are directly above us and why trap's work no matter how many levels above/below the enemy is.

Savsuds
27-03-2006, 03:53
An alpha tester I know has submitted 3 bug reports concerning the assasin teleport and unability to move after, especially when dealing with changes to elevation as Zero mentioned. I have fallen victim to the teleporting bug in RA many times having to wait for the other team to kill me slowly. I did manage to get my teammates to die close by so that I got use my res sig on them if needed.

The bug also prevents you from teleporting elsewhere or attacking.

Bobross
27-03-2006, 04:37
yup had the same problem...stuck on a rock.
-Emile

Nanashi
27-03-2006, 09:23
I have yet to experience said problems... then again my mobs were always insite and infront of me. I did see one of my friends get stuck though. It mainly happens when the mobs spawn on you, sometimes you target too soon and you teleport to their initial spot because technicly they haven't moved yet. You are watching an animation after all and until they start attacking you they're basicly ghosts.

Karuro
27-03-2006, 16:37
I often had this during the 12v12 and jade Quarrel missions. Got stuck in the air or in a tree. O_o
Trying to Death Charge 'out' of it, didn't work either. So I just had to wait till someone killed me. Alas, melee players couldn't hit me so I had to get killed by spells or arrows. T_T

Dria El
27-03-2006, 17:00
I had similar problems all weekend. I ended up inside rocks, sides of hills, in a wall, etc. And every single time, I tried everything to get out and could not. On top of that, about 20% of the time, when I would shadow step to the enemy I would find her running backwards waaay out of the fight (and sometimes into getting stuck). Overall, it was very very frustrating to play her. I had to be especially careful in how and where I attacked using the shadow stepping ability.

Dalliance Jade
27-03-2006, 17:08
I once ended up inside a rock while shadow stepping and of course couldn't get out. Another time, I shadow stepped to an enemy that was standing on the edge of a precipice, and I fell off and actually dropped for a good while before somehow magically reappearing on top of the precipice. Now, that was pretty cool!

Bobross
27-03-2006, 17:15
I fell through the floor once with my monk, walking in a town...same thing happened, just fell for a few seconds, then wound up back where I was.

kate sullivan
27-03-2006, 21:46
i think it has something to do with objects in your way... since u cannot normally go thru them when u try to shadow step thru them ur body cant physically get thru the object... once i was doing a quest and i killed all the oni everething then i was after th horn guy and i deaths charged at him when he was behind a rock and... i got stuck inside the rock... so form then on i try to make sure nothing is in the way before i teleport its a pain... but its a problem they will never fix... or at least for a while at least u knwo how they do things so dont get too excited if they say theyw ill fix it.