PC Gaming News
Results 1 to 10 of 10
  1. #1

    what port does GW/ArenaNet use?

    I have the exe files added to the firewall exceptions, opened up port 6112 on my router and I still cannnot log on. I have the code 058 error but I've looked up the solutions there and it isn't really helping.

    So maybe perhaps there's another port I need to open up?

  2. #2
    GWOnline.Net Member Achievements:
    10 PostsVeteran1,000 Posts5000 Experience Points6 months registered
    Saucermote's Avatar
    Posts

    1,396
    As far as I know just 6112, and perhaps 80, but 80 is generally open for web browsing anyway.

    Does it work if you temporarily disable the windows firewall?

  3. #3
    Yeah I'm still getting that error. Do you know if AVG would block it? I have the free version. I don't see anything for a filter.

  4. #4
    Saucermote is correct, Guild Wars needs unrestricted access to TCP ports 80 and 6112.

    AVG shouldn't be blocking access, but if you temporarily disable it and try launching Guild Wars, you can be sure.

    Finally, what router are you using?

  5. #5
    I was just reading this thread and was about to ask the same thing Tom Nook said until I seen his post... I can remember reading a while ago about issues with a certain Netgear router (perhaps it's more than one, who knows). If you have one you might want to check this page:

    http://uk.support.plaync.com/cgi-bin...i=&p_topview=1

  6. #6
    Yeah, it might be that you need to forward the ports on your router.

    But first can you run gw.exe -diag and post the log? Just to be sure that it's port 6112 that's having issues.

  7. #7
    A few other causes of Code 058 reported by users are linked here:

    http://guildwars.incgamers.com/showp...19&postcount=4

    -T

  8. #8
    All multiplayer games uses the default port 6112

    Port number actually doesn't matter unless you're running 2 programs on the same machine that both uses the same port.

  9. #9
    GWOnline.Net Member Achievements:
    10 PostsVeteran1,000 Posts5000 Experience Points6 months registered
    Saucermote's Avatar
    Posts

    1,396
    When I was having trouble with guild wars, I tried a few things on my router; Setting my computer to DMZ (not a generally safe option), and making sure I had port triggering and port forwarding enabled, and to the correct internal IP address. (UDP/TCP to be safe).

    Setting your computer to DMZ (demiliterized zone), meaning all ports auto forward to your computer, temporarily, will allow you to see if it is your router, or something else running on your computer.

    Note: I use a linksys router with a wired connection

  10. #10
    A port-trigger for TCP 6112 should be all you need. The "both" or "all" option will work, just be sure it's not specifically set to UDP. That is all that my router is set up for and it works flawlessly. (Newer Linksys wired/wireless gateway, connect via CAT-5)

    DMZ isn't bad for diagnostic purposes, just be sure to disable it once you're done fixing your problem. If you don't, you're asking for a major security problem.

    Also, if you have a software firewall on your computer, you may need to completely remove the allow command from it temporarily (not just disallow then re-allow). The next time you run GW, it should prompt you to either allow or disallow it, simply re-allow it. Some software firewalls don't like it when GW gets an update and you have to smack them up a little.
    Last edited by jayeddie; 12-05-2008 at 15:18.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •